Updating mingw Punjabi hot chat web portal


01-Jan-2017 18:21

Long story short: I need to help updating the gcc compiler that mingw uses to compile for windows within my linux build environment.When I installed the mingw version available by default in the Ubuntu repositories (3.0), I get an old version of the gcc compiler (4.6.3).So to do this, I installed a more recent version of mingw from source, which compiled a newer version of gcc. How can I specify the new mingw (and/or new gcc) for configuring, make, install? Long story short: I need to help updating the gcc compiler that mingw uses to compile for windows within my linux build environment.If you were using 14.04 instead of 13.10, this would be a moot point: the Min GW-w64 GCC in Trusty's repos is 4.8.2.It features a package management system to provide easy installation of packages, Pacman.It brings many powerful features such as dependency resolution and simple complete system upgrades, as well as straight-forward package building.

The one that came with mingw, by default, is too old. When I try ./configure, it is still targeting the old installation of mingw, and its out-of-date gcc.However, I need at least version 4.7 for what I am trying to compile.I have installed a more recent version of mingw (3.5.8) that contains gcc version 2.8.2, but I have been unable to use it since the previous version of mingw is still taking precedent over it.In use cases in which programs only check the return value for error codes, not for truncation, this can lead to out of bounds reads in subsequent functions since -1 will only be returned for any input larger than the buffer, but not for strlen == n.